2018年3月24日 星期六

在 CentOS7 上,Node.js 使用 npm 安裝模組出現錯誤

出現以下錯誤訊息
npm: relocation error: npm: symbol SSL_set_cert_cb, version libssl.so.10 not defined in file libssl.so.10 with link time reference

查詢目前 openssl 版本
$ openssl version
OpenSSL 1.0.1e-fips 11 Feb 2013
更新 openssl
$ yum update openssl
更新 openssl 後,即可正常安裝
$ openssl version
OpenSSL 1.0.2k-fips  26 Jan 2017



參考:
https://stackoverflow.com/a/46476879

沒有留言:

張貼留言